1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[WORKING] New ADSBExchange base image v1.0

Discussion in 'Feeding' started by James, Dec 31, 2017.

Tags:
  1. James

    James Administrator Staff Member

    NOTE: Grafana current build supports US date format and International data format for the Dashboard. Currently does not have the option for European formats with commas or DD/MM.

    ===
    July 18th 2018 build supports Pi 3B and Pi 3B on 2.4ghz wireless.
    ===


    Initial Release 12-31-17:

    Image will expand file system on first boot, then reboot. Supports ADSBexchange.com MLAT.

    Features include:
    • adsb-config.txt in /boot
    • ssh user: pi password: adsb123 port 3226
    • Raspbian GNU/Linux 9.1 (stretch)
    • Custom Grafana Dashboard port:3000
      • login: adsb password: adsb
      • login: admin password: admin
    • Prometheus metrics
    • Dump 1090 latest
    • MLAT Client
    • OpenLayers Maps:
      • Vector World Map
      • Vector Roads
      • Vector US States
      • US Sectionals
      • US IFR High
      • US IFR Low
      • US IFR High Enroute
    • US NEXRAD
    • Major Airports
    • GPS for Time Sync Offline (not setup by default)
    • Various performance fixes

    Release Jan. 5 2018 V1.02
    • Fixed a few typos
    • Added WIFI Config using wpa_supplicant
    • Added basic dashboard at root IP
    • Fixed a bunch more typos :)
    • Refactored load scripts
    • adsb-config.txt in /boot is now read into /tmp/params
    • Fixed issues with Windows editing new line characters
    • Added fun
    Release Jan. 5 2018 V1.2.2
    • lots of bug fixes
    • socat
    • work for Pi Zero fork
    Release Jan 27 2018 V1.2.3
    • 'dash' fixed - see explaination
    • no need to reimage if you edit yourself, save your adsb-config.txt if you reimage.
    Release Feb 2 2018 V1.2.4
    • Descalated so things don't run as root
    • Changed how WiFi is configured on boot [experimental]
      • Uses WPA_supplicant command line config
    Release Feb 19 2018 V1.2.4a
    • Fixed a frustrating SSID / Password issue when deploying in remote poor internet areas
    • Fixed poor wifi signal handshake slowness
    Release Feb 21 2018
    • Added config for PRIVACY to remove MLAT map dot - privacy enabled by default
    Release Feb 22 2018 V1.24c
    • Fixed dump1090 missing distance rings from lat/lon
    • Added remote support tunnel
    Release Apr 18th 2018 V1.27vlan
    • Added cellular initial dongle support
    • Added 978 mhz UAT support for 2nd SDR
    • Added ZeroTier VLAN for remote support
    • Various small fixes across sh files
    • Removed explanations in adsb-config.txt for readability
    Release Jul 10th 2018 V1.28vlan
    • Added Pi 3B+ support
    • Fixed bash typo warning
    • sudo apt-get update and upgrade
    • Fixed minor typos in scripts

    DL: https://www.adsbexchange.com/downloads/adsbx-v1.28vlan.zip

    EDIT: Aug 22nd 2018 - Download to 1.28 put back up.
    Needs this fix ( https://www.adsbexchange.com/forum/...rget-host-is-not-resolved.623148/#post-626660 ), if you have the issue.

    1.29 and above will have it already added. I want to add a few more things before I publish a new update.

    SAMPLE CONFIG:

    Code:
    LATITUDE 3.366320
    LONGITUDE -11.694614
    ALTITUDE 400
    ADSBXCUSTOMPORT 30005
    ADSBXNAME "feeder-name"
    ENABLE_WIFI yes
    WIFI_SSID "SSID"
    WIFI_PASSWORD "password"
    KEY_MGMT "WPA"
    #################
    #DEFAULTS BELOW
    #DO NOT CHANGE
    #UNLESS NEEDED
    #################
    MLATADSBXSERVER "feed.adsbexchange.com:31090"
    ADSBXCUSTOMURL "feed.adsbexchange.com"
    REMOTE yes
    PRIVACY yes
    MLAT yes
    DUMP yes
    UPDATE no
    ENABLE_BT no
    SHELLBOX no
    UAT no
    UATPORT 30005
    CELLULAR no
    


    HOW TO BURN:
    Will fit on 4GB SD
    Unzip and burn like any other image

    Linux users
    open a terminal
    type lsblk

    [​IMG]

    sudo dd if=/location/of/image.img of=/dev/mmcblk0 bs=1M status=progress

    Windows users
    https://etcher.io/

    HOW TO SETUP & FEED ADSBEXCHANGE
    Mount image and edit adsb-config.txt that is in the /boot partition.


    SCREENSHOTS:
    Screenshot_2018-01-05_23-39-49.png
    [​IMG][​IMG] [​IMG] [​IMG]
     
    Last edited: Aug 22, 2018
  2. James

    James Administrator Staff Member

    Image has been running, will leave it going until something weird happens. When does yours stop working?
     
  3. Varies randomly about 3-8 hours
    No pattern to what may trip it
     
  4. James

    James Administrator Staff Member

    Running fine all night here. I wonder if you might have a bad SD card or something.

    If Grafana is crashing, it would error like below. I forced a Grafana crash here. Screenshot_2018-01-23_07-57-24.png
     
  5. James

    James Administrator Staff Member

    If prometheus crashes - dashboard will look like this. Notice the errors (!) on each panel. Screenshot_2018-01-23_07-59-50.png
     
  6. I have now been running the image for 24 hours on the 4gb Sandisk microsd card and it has been stable
    Thank you James for all your help
    What sd cards do members here use for their raspberry pi's?
    I have read about levelling in sd cards
    What are members thoughts?
     
  7. Cam

    Cam New Member

    This is really nice.

    The "Data Receive" and "Data Transmit" gauges are not working for me though - they show zero all the time. Any ideas on how to fix them?

    Thanks.
     
  8. James

    James Administrator Staff Member

    It depends on your wifi or lan. Just have to change it. Login with admin/admin and edit the gauge

    It's all setup, click the eye on the right to toggle off and on. eth0 is lan, wlan0 is wifi.

    Screenshot_2018-02-19_20-10-48.png Screenshot_2018-02-19_20-08-47.png
     
    Cam likes this.
  9. Cam

    Cam New Member

    Perfect. Thanks!
     
  10. James

    James Administrator Staff Member

    You are welcome! Thanks for feeding!
     
  11. Wakko

    Wakko New Member

    Hello,
    I have to say that I love this image! The grafana dashboard is sweet.

    I have a couple questions: is there anyway to make the data that grafana is using persistent? I’m assuming it’s all written in memory so as not to wear out the SD card (or not use up capacity?)

    Also, is it possible to feed any other sites? I started feeding ADSBexchange about 20 minutes after getting my pi out of the box, but was just curious if I could contribute to anything else as well.

    Thanks!
     
  12. James

    James Administrator Staff Member

    It saves 4 hours to ram tmp filesystem, If you hosted your own prometheus on the same network then configured it scrape the pi /metrics. Then you could have as much persistence as you wanted. https://prometheus.io/

    Theoretically it should be able to feed FA and FR24 - but I have not tested as FA and FR24 make changes to the dump1090 configuration and don't want to see to play nice.


    One a side note we are coming along nicely with an infrastructure overhaul that will let us build out some stats - not the extent of Grafana on the pi but maybe given enough time and money we could do it. That would require multiple terabytes of web and database hosting for a project that already costs it's creator a significant amount of outlay every month.
     
  13. steve gee

    steve gee Member

    I just got the latest image pretty much working on my RPi3 (feeding custom port, WiFi connection, etc)
    When I navigate to http://adsbx-custom.local/dump1090/gmap.html with my browser I noticed the following anomalies:
    • My location dot and range rings are missing.
    • When I click "reset map" I'm zoomed over to Europe even though I'm in North America
    • The distance column is missing.
    I turned off the PRIVACY setting in /boot/adsb-config.txt thinking that was causing problems but it's still the same.

    My previous RPi3 setup using 1.15-dev dump1090-mutability showed my location dot and the distance column.
     
  14. James

    James Administrator Staff Member

    Hmmm .. that's interesting .. come to think of it I don't seem to have distance rings on mine right now either ... but there were there ...... prior ...

    Let me look at it ..... you can replace the html .... I might not be using ~dev ... will fix it in the next update if I can
     
  15. James

    James Administrator Staff Member

    Figured it out. It's all because some jagoff was complaining that dump1090 and whatnot ran as root. So when I deescalated the permissions - shit hit the fan .. fixed it but I have to learn to simply say no to the 1 out of 100 nit pickers
     
  16. steve gee

    steve gee Member

    Which script(s) did you change to fix it? I can have a look at getting dump1090 running non-root if you want. I do Linux in my day job.
     
  17. MDA

    MDA Administrator Staff Member

    dump1090 is running as user selected during setup (default dump1090).
    MLAT client uses root.
     
  18. James

    James Administrator Staff Member

    su pi -c '/usr/bin/dump1090-mutability --aggressive --quiet --net --ppm 0 --fix --lat $MLATITUDE --lon $MLONGITUDE --max-range 350 --net-ri-port 0 --net-ro-port 30002 --net-bi-port 30004,30104 --net-bo-port 30005 --net-sbs-port 30003 --net-heartbeat 30 --net-ro-size 5000 --net-ro-interval 1 --net-buffer 2 --stats-every 3600 --write-json /run/dump1090-mutability --write-json-every 5 --write-json-every 5 --json-location-accuracy 1'

    But since that opens a new terminal with the user pi ... the lat and lon variables do not get set .. awkward ... stupid bash .. so

    export MLATITUDE=$MLATITUDE
    export MLONGITUDE=$MLONGITUDE

    Setting them system wide. It's hacky but works.

    File: /home/pi/adsbexchange-dump1090_maint.sh

    Always open to things we can do better without shipping a binary that people can't edit or see what it's doing.
     
    Last edited: Feb 23, 2018
  19. Federica Ruggeri

    Federica Ruggeri New Member

    Hi guys,
    I'm trying to start a "serius and dedicated" method to feed adsbexchange and finally I found a new adsbexchange featured image.
    But, Im really sorry for my very stupid ask... why I can't find any image to burn on my sd card on this discussion?
    Could somebody explain me where download the image?
     
  20. James

    James Administrator Staff Member

    I took DL down to fix some bugs. I'll post the DL link.


    REMOTE no
    PRIVACY no

    in the adsb-config.txt

    remote disabled reverse ssh tunnel for remote support
    privacy no makes map dot appear in MLAT map